No world or asset format I download is OK


#1

Hi there I am very new to Jahshaka
Just downloaded the latest 0.6.1a version and I wanted to download a world or an asset or just import my own model.
Any world or asset I download (from the page I get directed to by the program) and try to import leads to a “incompatible world/asset format” and the info that it was created in an earlier version and I can recreate it.

Oh yes - and all the sample worlds tell me the same deprecated message.

In Assets I haven’t been able to import any obj or .jaf so far either

Checked the tutorial but anything mentioned there results in the behaviour described above.

I guess I am missing a big piece of the puzzle here??
It should be straight forward - or not??

Cheers


#2

hey barcud,
have you tried importing the world from the worlds view?


#3

I tried the worlds from the worlds view and the assets from the assets view.
In the world view I can’t even use a sample world - I get the choice of 4 (Metcaps …) but when I select one I get the Incompatible world format message again.


#4

@Barcud_Revnik which operating system are you using? and where did you download the new version from?


#5

Ooops sorry - forgot to mention that
WIndows10 and downloaded it yesterday from http://www.jahshaka.com/download/ which leads to

https://sourceforge.net/projects/jahshakafx/files/Jahshaka-binary/3.0/jahshaka-win-0.6.1-alpha.exe/download

First downloaded the 0.6.1 - was reminded on start that I should update - updated and - well - can’t open anything.
Is there a way to attach a screen-cast here in this forum??


#6

You could do a screencapture with obs(https://obsproject.com/) then upload your video to dropbox/googledrive/onedrive and share the link with us.


#7

OK, screen grabbed and here it is (unlisted)

I just hope I didn’t just make a massive fool out of me by missing the obvious !!


#8

I’m thinking it might be a permission issue causing this. Could you try running the app in admin mode and tell me if you’re facing the same issue?


#9

Just tried it in admin mode and the problem is still there - exactly the same behaviour.

OK, I really don’t know much about the program but I had a bit of a look around in the zip file of the world.
The world seems to have a sqlite file which presumably contains all the information to “create” the world. Is it possible that the new 0.6.1a version just rejects everything because it reads some version info form somewhere (e.g. the sqlite DB) and immediatley rejects it??

Then again it seems I am the only person who has those problems??
Uninstalled it and reinstalled it but still the same.
Machine is an i7 16GB RAM and GTX970 graphics - so that should not be the limiting factor either.

Really no idea what is going on.
Did you have a look at the screen cast?
I should just be able to open a sample world like I tried to - shouldn’t I ??


#10

No, it’s not database related, when you import a file, the contents are extracted to a temp location first (C:\Users\USERNAME\AppData\Local\Temp titled Jahshaka- and appended with a random hash) to do some checks, in particular a .manifest file has to be inside or it will give the message you’re getting now. The only conclusion is that for some reason you don’t have write permissions to your temp folder so the files aren’t getting copied. As a last ditch effort can you try creating a new windows account and trying again there?


Additionally can you try the methods posted here? https://answers.microsoft.com/en-us/windows/forum/windows_vista-windows_programs/unable-to-write-to-the-temp-directory-in/113e0936-6231-4330-968e-2a6a6a76a524


Thanks for your persistence and time as this is the first we’re getting a report about this issue. If none of these work we will probably have to look into eliminating that step in the next version.


#11

Well let’s put it this way - I can go to the Temp folder you and create files and folders in there.
I ran a trace with https://docs.microsoft.com/en-gb/sysinternals/downloads/procmon

  • a process monitor just looking at files read/written

It shows that the zip files is read, 7zip is called and the new directory is created in Temp and files are written.

21:29:24.0808143	Jahshaka.exe	4068	IRP_MJ_CREATE	C:\Users\bernd\AppData\Local\Temp\Jahshaka-zxPK5t	SUCCESS	Desired Access: Write Attributes, Synchronize, Disposition: Open, Options: Synchronous IO Non-Alert, Open Reparse Point, Attributes: n/a, ShareMode: Read, Write, Delete, AllocationSize: n/a, OpenResult: Opened

Not sure where it goes wrong - I have created a trace using procmon which I can send (since I am not able to upload it) if you are interested.

I can assure you that there is no problem with writing to temp on my computer as a user. Blender and lots of other programs write their data there.

So - question - is it really that I am the only person who can’t open - well - basically anything??
If there is anything I can do to help just let me know.
Cheers


#12

It might be possible to install to the C instead of the program files directory. The permissions seem to have changed in windows 10. It could be possible to try running the 32 bit version with another install directory. The last thing i can think of is a missing dependency.I still had no luck importing objects into the world. It shows them listed without icons, but everything else works.


#13

Can you open up a specific thread for any issues you encounter so we can check it out, thanks. Also feel free to drop by our slack channel https://join.slack.com/t/jahshaka/shared_invite/enQtMzY0OTkyNDgwNTkyLTM2ZTMwY2FkZGIzNWNkZTljZjUzZDRlM2NiMTUyYTE4NGY1MzE1MjYzYTU4MGE2NWNhMDdhMTg0OTBiYzMxNWI


#14

OK, uninstalled it from my F drive and installed it on C in the default location (I don’t do that really - My C drive is only for OSs) and voila - it works.
Uninstalled it from C and reinstalled it to F:/Programs and - same problem - nothing goes.
Uninstalled and installed it to D - nothing works

So it seems that for some reason it needs to be on C - D and F did not work for me.
Might need some looking into.
Not everybody wants all the programs on C

Hope it helps.


#15

It occurred to me to ask if you were on a different drive but I saw in the trace log you had a C:/ path so skipped over that. You’re right, this was something that was assumed sometime back and wasn’t amended and should be changeable in your app preferences as to where to look for a data path and we will make sure it works out of the box automatically in the next version. Thanks again!