Crash when building 0.6.0


#1

I checked out the latest master code from GitHub and built Jahshaka on windows - then when trying to import the latest Hill Side Villa from JahFX the application crashed…

crash%201

crash%202

let me know what to do please!


#2

This also happens . using the latest code from dev - same error crashing the app when loading hill side villa


#3

Note i am using Qt 5.9.2, tried using 5.9.3 on OsX and it works fine so upgrading Qt on windows now to 5.9.3 and will test again


#4

This was caused by a couple specific scenes being exported with an earlier development version of the software, consequently they had some metadata that was malformed when being read in the newer release version which in turn caused Qt to throw an exception that wasn’t being handled.

The affected scenes have been updated and a more stringent check added to make sure this will not happen again in the future. If you downloaded 0.6.0a you are urged and will be prompted to update to version 0.6.1a and the same goes for anyone building from source.


#5

great thanks! i have built using that latest patched code for 0.6.1 and its working fine for me - will do some more testing and let you know… the new water shader looks awesome